Go Back   BMW i3 Forum: A BMW i3 Forum > BMW i3: Main > New Member Introductions

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 11-20-2014, 05:02 PM   #1
Junior Member
 
Join Date: Nov 2014
Location: London UK
Posts: 2
Default Hi All

I've had my all electric i3 since August and by and large am really pleased with it. All of my usage is in and around London, with a 15 mile commute, so on average I tend to get 2 days usage from a full charge. I'm waiting to get a Chargemaster box fitted in my garage, but luckily I can also charge at my office near City Airport.

The only issue I have, is that for some reason it suddenly stopped displaying public charge points on the SatNav. I haven't had a chance to go back to the dealer I purchased from and I suspect that they will just refer me to their service centre, which for me is in a really inconvenient location.

Has anyone out there had a similar problem and if so, have you any ideas on how to solve it?

Clive
Evil_C is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 06:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.1